Ask a question

We will try to contact this business to get an answer for you.

Terms of Service
Post answer
Cancel

Pip boy

How can I order a replacement piece for my pip boy?

Show

Skyrim special edition

I try to use mods in skyrim on my xbox 1 but all i get when i try to download is "this operation cannot be completed

Show

Account

Why is Bethesda saying i already have a account if ive never made one? I bought Skyrim V special edition for my Xbox one and i wanted to make an account to use mods but when i went to create one and put all of my info in it said my Email was already in use im super Confused cause i never made a Beshesda account and i havent tried until now and im ticked off

Show

Fallout 76 beta

I recently pre ordred fallout 76 and I realized the account the beta went to does not have my Xbox live account to it and was wondering if there is anything you can do so I can get the beta I still have the code and everything

Show

Login error

I recently purchased elder scrolls online on my playstation 4 and at first it seemed great but only after the second day of having it I was faced with a problem in which when i tried to pick my character i had created and it would start to load then kick me back to the menu screen saying that it was having trouble connecting to the server but then the next day it wouldn't even let me get that far with out saying it had a problem connecting but it is not my connection considering i have about a 5gb connection speed at its lowest. If you could help me and maybe give me some tips on how i could fix this it would be much appreciated.

Show

About skyrim bug fix

Bethesda pleased help with this problem When I start skyrim it's OK but when I move the mouse it leaves a trial behind them all the menus I open even if I close it's image doesn't go from the screen it's like a image layer is formed in front of it the game screen I cannot see the gameplay only the black screen and the images of the menus even if I open and closed it

Show

I need help call me

+1-226-973-9790 is my phone number

Show

New Vegas dlc

I installed all the dlc, but it won't show up, and wants me to pay for it again. I purchased the Dlc on disc but unable to play it I refuse to pay for something I already paid for.

Please help me fix this situation.

I am playing on an Xbox one. Any help would be appreciated.

Show

HELP

So I play fallout 4 (G.O.T.Y. edition) and I was like level 30 or something and I let my dad play and then saved his data, and when he finishes I try to find my data AND ITS NOT THERE.

I’ve checked everywhere from my account my saves on the game and I can’t find it! I love this game so much but this is insane.

Show

I can't link my bethesda.net account to my Xbox One

Recently I got Skyrim special edition for the Xbox One I had the option to make a quick account for mods and I did well now I want to actually sync my real bethesda.net account to my Xbox but it's not even giving me a chance to log in it gives me a create account message and when I try to put in my email it says too many requests I have no idea what to do or how to fix this I've tried looking everywhere on the internet maybe you guys can help

Show

Skyrim mods

How do I get full list of mods on Xbox one

Show

Bad service

Will doom get a ps4 pro patch like xbox x

Show

Why does my fallout 4 glitch quite a bit

So I'm playing fallout 4 then the battle music goes on during a battle but when I finish the battle it keeps going. Then I stopped playing for a week then was still on then I fast travel to diamond city and I go in 3rd person and my arm (pip-boy/left arm) inside my body and the game crashes. Btw I'm playing on PS4

Show

So what do i need to do?

So i bought The Elder Scrolls: Tamriel Unlimited recently from Steam on my PC. I download the launcher and updated everything over night.

But when i try to press the play button on the launcher page it litterally does nothing.

No loading icons or anything. Do you all have any idea what this could be?

Show

Skyrim Lag

After a week of not playing, I recently put Elder Scrolls Skyrim on to start playing again and the game seems to be lagging quite a bit. When my character walks or runs, it seems to stutter to the point that I can barely move the character.

This is quite aggravating and I'm hoping theres some solution to this issue. Not sure if there has been a recent patch update file for the game which could be causing this to happen.

I tried re-installing the game, cleaning the disc and trying my brother's disc which he owns and the problem still persists. If anyone could give me help ASAP, it would be beneficial.

Show

code for prey cosmonaut shotgun pack does not work ps4

I have recently purchased a copy of prey on ps4, it came with a cosmonaut shotgun dlc code in the box, however this code keeps saying invalid, it is an english copy and an english account, it was bought in england.

Show

In fallout 4 my camera moves on it's own and my game lags is there a solution?

When I walk the camera will jolt to the left for no reason

Show

Questions 17